Sorry for the inconvenience.  Chance of typos in templates, the navigation header should be functional for most versions of the handbook.
Potential remains for unforeseen breakage primarily in the handbook portion of the wiki.
Notice will be up until above verified and no other troubles found from recent modifications.

Difference between revisions of "Talk:Installation Troubleshooting"

From PC-BSD Wiki
Jump to: navigation, search
(other refs)
m (the solution)
Line 19: Line 19:
  
 
=== the solution ===
 
=== the solution ===
(from a [http://paulscomputernotes.blogspot.com.au/2012/06/installing-freebsd-90-drives.html blog post])
+
 
 +
; (from a [http://paulscomputernotes.blogspot.com.au/2012/06/installing-freebsd-90-drives.html blog post]):
 +
 
 
Here's where I found it and all that is need is to open the loader prompt during the CD/DVD/USB boot (by pressing 2 or ESC) and adding the following line:
 
Here's where I found it and all that is need is to open the loader prompt during the CD/DVD/USB boot (by pressing 2 or ESC) and adding the following line:
  
Line 28: Line 30:
 
     boot
 
     boot
  
Once the USB key has booted you can add the line
+
Once the USB key has booted you can add the line
  
 
     debug.acpi.disabled ="hostres"
 
     debug.acpi.disabled ="hostres"
Line 35: Line 37:
 
In any event, once you have installed FreeBSD 9.0-RELEASE, you still need to add this line to /boot/loader.conf.
 
In any event, once you have installed FreeBSD 9.0-RELEASE, you still need to add this line to /boot/loader.conf.
  
====other refs====
+
==== other refs ====
Also documented in Open issues of [http://www.freebsd.org/releases/9.0R/errata.html FreeBSD v9.0R errata]
+
 
 +
Also documented in Open issues of [http://www.freebsd.org/releases/9.0R/errata.html FreeBSD v9.0R errata].

Revision as of 10:14, 3 January 2013

Not sure exactly how/where to place this, but it ought to be added in some form.

Contents

Error 19

the background

(from a FreeBSD forum post)

In any event, booting to FreeBSD from Grub now leads to Code:

Mounting from ufs:/dev/ad4s3a failed with error 19

and thereafter to a mountroot prompt. Typing '?' at the mountroot prompt provides no GEOM managed disk devices whatsoever.

At this stage, I created a re-install CD of FreeBSD 9.0-RELEASE and booted from it. However, the boot ended with Code:

Mounting from cd9660:/dev/iso9660/FREEBSD_INSTALL failed with error 19

and then the mountroot prompt. Once again, typing a '?' at the prompt showed no GEOM managed disk devices.

the solution

(from a blog post)

Here's where I found it and all that is need is to open the loader prompt during the CD/DVD/USB boot (by pressing 2 or ESC) and adding the following line:

   set debug.acpi.disabled ="hostres"

and then booting with

   boot

Once the USB key has booted you can add the line

   debug.acpi.disabled ="hostres"

to /boot/loader.conf, if you intend to use the key again. In any event, once you have installed FreeBSD 9.0-RELEASE, you still need to add this line to /boot/loader.conf.

other refs

Also documented in Open issues of FreeBSD v9.0R errata.

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox